个人工具
名字空间
变换
操作

Plogger/安装与升级

来自站长百科
跳转到: 导航, 搜索

目录

环境需求

  • MySQL 3.23或以上版本;
  • PHP 4 或以上版本;
  • GD 1.0 或以上版本;

Plogger安装

  1. 下载Plogger程序,解压文件至本地;
  2. 利用FTP上传工具将解压的文件上传服务器的根目录或其下的子目录;
  3. 利用你的服务器控制面板创建一个MySQL数据库和账户;
  4. 在浏览器中输入:http://www.yoursite.com/plogger所在目录(如果放在根目录的话则不用写)/plog-admin/_install.php 运行Plogger的安装脚本,根据提示进行Plogger的安装;
  5. 安装完成后,即可登录到后台开始配置你的相册

Plogger升级

升级之前:

在你将Plogger升级到版本 1.0-RC1之前,必须确保备份了已经存在的所有文件,通过FTP和phpMyAdmin,将备份文件保存在本地。如果你定制了主题,翻译,或其他的一些第三方脚本文件,也请同样备份;

之前的任何版本升级至Plogger 1.0-RC1:

  1. 首先是备份,之前已经说明;
  2. 上传和覆盖所有文件,除了plog-config.php文件,至服务器;
    • 旧的plog-config.php文件应该继续工作,但是可以有一些新的选项可供设置;
    • 如果之前使用的是Cruft-Free URLs,则不要覆盖.htaccess文件,如果你不小心做了的话,可以登录到后台,Admin->Options,然后保存options来重新创建.htaccess文件;
    • 如果你修改了下载的文件里三个主题文件中的某个文件,请不要对修改的主题文件夹进行重命名,也不要上传新的主题文件夹;
  3. 在浏览器中输入:http://www.yoursite.com/plogger-folder/plog-admin/_upgrade.php ,运行升级脚本;
  4. 根据提示,进行每一步升级步骤即可;

参考来源

留言